wstest.py does not run on my mac ( osx 10.7.3 )

#1

Hi all,

i want to write a realtime web application which uses the wamp protocol. AutobahnPy seems to be a perfect solution for my demands.
So i decided to give it a try. I have downloaded the Testsuite and tried to run to wstest.py demo on my my mac.

Unfortunately this ends up in something like this :

snip >>>>>

python demos/autobahntestsuite/autobahntestsuite/wstest.py

WARNING: Running on BSD or Darwin, but cannot use kqueue Twisted reactor.

=> No module named kqsyscall

To use the kqueue Twisted reactor, you will need:

  1. Python >= 2.6.5 or PyPy > 1.8

  2. Twisted > 12.0

Note the use of >= and >.

Will let Twisted choose a default reactor (potential performance degradation).

(Program stops execution here )

$python

Python 2.7.2 (v2.7.2:8527427914a2, Jun 11 2011, 15:22:34)

[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin

Type “help”, “copyright”, “credits” or “license” for more information.

import autobahn

import twisted

print autobahn.version

0.5.1

print twisted.version

[twisted, version 12.0.0]

<<<< snap <<<<<<

Well, python is 2.7.2, should be ok. And Twisted 12.0.0 is the newest version according to their website.

What is going wrong here ? Any help appreciated.

Kind Regards
Juergen Mutz, Germany

0 Likes

#2

Sorry for terse answer … am on the road. Try Twisted Trunk … Kqueue support will be in Twisted 12.2

···

Am 04.05.2012 12:49 schrieb “Jürgen Mutz” postan.ju...@googlemail.com:

Hi all,

i want to write a realtime web application which uses the wamp protocol. AutobahnPy seems to be a perfect solution for my demands.
So i decided to give it a try. I have downloaded the Testsuite and tried to run to wstest.py demo on my my mac.

Unfortunately this ends up in something like this :

snip >>>>>

python demos/autobahntestsuite/autobahntestsuite/wstest.py

WARNING: Running on BSD or Darwin, but cannot use kqueue Twisted reactor.

=> No module named kqsyscall

To use the kqueue Twisted reactor, you will need:

  1. Python >= 2.6.5 or PyPy > 1.8
  1. Twisted > 12.0

Note the use of >= and >.

Will let Twisted choose a default reactor (potential performance degradation).

(Program stops execution here )

$python

Python 2.7.2 (v2.7.2:8527427914a2, Jun 11 2011, 15:22:34)

[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin

Type “help”, “copyright”, “credits” or “license” for more information.

import autobahn

import twisted

print autobahn.version

0.5.1

print twisted.version

[twisted, version 12.0.0]

<<<< snap <<<<<<

Well, python is 2.7.2, should be ok. And Twisted 12.0.0 is the newest version according to their website.

What is going wrong here ? Any help appreciated.

Kind Regards
Juergen Mutz, Germany

0 Likes