wss only on JS ??

#1

Hi … i want talk about wss example ( in crossbar examples ) … where the client is using web page JS to connect to server wss ( wsuri = “wss://127.0.0.1:8080/ws” ), i want make a client with Python, but when i try a simple thing like that :
if name == ‘main’:
runner = ApplicationRunner(url=u"wss://localhost:8080/ws",realm=u"realm1")
runner.run(Component)

client want join the realm !!! please! is wss supported only over https from webBrowser ??? … help ! im blocked with this … i f i can pass it i ve to add SSL parameter … also ? i dont find ssl parameter on AutobahnJS !! ?? thanks

0 Likes

#2

Hi,

don't worry, AutobahnPython works with wss too:)

ApplicationRunner has a "ssl" parameter to pass in an appropriate SSL context thing (which is different for Twisted and asyncio).

Which one are you using? I mean Twisted or asyncio?

If your server (the WAMP router .. btw, which one are you using?) employs certs issued by a CA built into the platform's truststore (which platform btw? Windows, Linux, ..?) you should be fine without providing the "ssl" parameter.

However, if you are using server certs issued by CAs not in the platform truststore, like it's the case for self-signed certs, or certs signed by your own CA, then you have to pass in an appropriate context.

Please reply and fill in the ?? in above, I'll provide more specific infos then ..

Cheers,
/Tobias

···

Am 02.03.2016 um 20:53 schrieb Adel Benaida:

Hi .. i want talk about wss example ( in crossbar examples ) .. where
the client is using web page JS to connect to server wss ( wsuri =
"wss://127.0.0.1:8080/ws" ), i want make a client with Python, but when
i try a simple thing like that :

*if __name__ == '__main__':

     runner =
ApplicationRunner(url=u"wss://localhost:8080/ws",realm=u"realm1")
     runner.run(Component)
*
client want join the realm !!!! please! is wss supported only over https
from webBrowser ??? .. help ! im blocked with this .. i f i can pass it
i ve to add SSL parameter ... also ? i dont find ssl parameter on
AutobahnJS !! ?? thanks

--
You received this message because you are subscribed to the Google
Groups "Autobahn" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to autobahnws+...@googlegroups.com
<mailto:autobahnws+...@googlegroups.com>.
To post to this group, send email to autob...@googlegroups.com
<mailto:autob...@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/autobahnws/c4ab1829-07ce-4f0a-be56-f7a7fe77f76f%40googlegroups.com
<https://groups.google.com/d/msgid/autobahnws/c4ab1829-07ce-4f0a-be56-f7a7fe77f76f%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.

0 Likes

#3

Hi tobias … i didnt respond because we found solution for that problem … but now … we ve another … we could send client certificate by the ssl parameter, and read it in the router. The problem is that its only working when the client certificate is issued by a CA, and we must add the ca.cert.pem to router config !!! we learnt in the doc that its optional, we want send a selfsigned certificate … thank you so much tobias !! thank you for you re help

0 Likes

#4

Hi Adel,

it would be nice for others on the mailing list if you’d follow up on your previous question with the solution/answers on the questions posed by Tobias.

Furthermore, if you have a new question: start up another thread.

Thanks for starting interesting discussions!

···

Op zondag 6 maart 2016 13:11:29 UTC+1 schreef Adel Benaida:

Hi tobias … i didnt respond because we found solution for that problem … but now … we ve another … we could send client certificate by the ssl parameter, and read it in the router. The problem is that its only working when the client certificate is issued by a CA, and we must add the ca.cert.pem to router config !!! we learnt in the doc that its optional, we want send a selfsigned certificate … thank you so much tobias !! thank you for you re help

0 Likes

#5

Yes. So im on ubuntu 14.04 + using twisted. I failed first time because i was trying to connect new client to a router that use not the appopriate configuration.. I was working over a router from the wss example. Now i Turned to the dynamique tls authentification. And i tried to send a selfsigned certificate .. But in thé router it logs : "client certificate not presented" .. But when we add a ca and client certificate issued by ca it works !! I thought ca is optional .. Note that my project is based on dynamique tls authentification example .. I just removed backend container and added a remote client ! Thanks SIRS

0 Likes