What happened to TLS v1.0 in Crossbar 0.12.1

#1

Has TLS v1.0 been dropped?

I have a client using Java 7 who wont be able to update to java 8 for 6 months to a year and it seems he can no longer connect

based on both mine and your Qualys report is looks like everything is TLS v1.2 does this mean crossbar isnt supporting TLS v1.0 or am I missing a config option somewhere?

0 Likes

#2

I think this answers my question…https://github.com/crossbario/crossbar/issues/620

Can I vote this feature up as hard coding TLS to 1.2 alienates a lot of enterprise clients who cant update quickly

···

On Wednesday, February 24, 2016 at 10:05:48 PM UTC-8, Greg Keys wrote:

Has TLS v1.0 been dropped?

I have a client using Java 7 who wont be able to update to java 8 for 6 months to a year and it seems he can no longer connect

based on both mine and your Qualys report is looks like everything is TLS v1.2 does this mean crossbar isnt supporting TLS v1.0 or am I missing a config option somewhere?

0 Likes

#3

Greg,

just add a +1 on the issue.

···

Am Donnerstag, 25. Februar 2016 07:15:20 UTC+1 schrieb Greg Keys:

I think this answers my question…https://github.com/crossbario/crossbar/issues/620

Can I vote this feature up as hard coding TLS to 1.2 alienates a lot of enterprise clients who cant update quickly

On Wednesday, February 24, 2016 at 10:05:48 PM UTC-8, Greg Keys wrote:

Has TLS v1.0 been dropped?

I have a client using Java 7 who wont be able to update to java 8 for 6 months to a year and it seems he can no longer connect

based on both mine and your Qualys report is looks like everything is TLS v1.2 does this mean crossbar isnt supporting TLS v1.0 or am I missing a config option somewhere?

0 Likes