wamp.session.get returning null

#1

Hi. We are having a problem trying to isolate an intermittent and inconsistent problem.

We are using wamp.session.get to get the authid of the caller. Mostly this works flawlessly. However, some of our developers consistently have a problem were wamp.session.get is returning null but the session id does exist when you do a lookup with wamp.session.list.

What could be happening to cause wamp.session.get to return null or some people and not for others?

Thanks in advance.

Regards,

Andrew Eddie

0 Likes

#2

Hello Andrew!

with something like this it’s pretty much impossible to give any aid remotely. Is there anything regarding the developer machines etc. which is different for the developers that encounter this error?

Regards,

Alex

···

Am Montag, 28. Dezember 2015 08:09:40 UTC+1 schrieb Andrew Eddie:

Hi. We are having a problem trying to isolate an intermittent and inconsistent problem.

We are using wamp.session.get to get the authid of the caller. Mostly this works flawlessly. However, some of our developers consistently have a problem were wamp.session.get is returning null but the session id does exist when you do a lookup with wamp.session.list.

What could be happening to cause wamp.session.get to return null or some people and not for others?

Thanks in advance.

Regards,

Andrew Eddie

0 Likes

#3

We don’t really know what was exactly causing the problem, but when we removed “cookie” as a possible authentication method the problem went away.

Regards,

Andrew Eddie

0 Likes