Upgrade crossbar, then Router crash on startup with no error message

#1

A coworker did a fresh install of crossbar today, it gave him:

Crossbar.io: 0.12.1
Autobahn: 0.13.0
Twisted: 16.0.0

He was not able to run the simple app that I had given him (error message on unrecognized args to ApplicationRunner - perhaps a change is required for newer Autobahn version?)

I was at:
Crossbar.io: 0.12.1
Autobahn: 0.12.1
Twisted: 15.5.0

So I did a pip install --upgrade crossbar and then had an installation with matching versions.

I wanted to debug the app, but first needed to restart the Router. The router failed almost instantly and gave no error message.
Perhaps there is a change required in the config file, too? If so, it gave me no indication of such.

I reverted back my autobahn, so that I now have:
Crossbar.io: 0.12.1
Autobahn: 0.12.1
Twisted: 16.0.0

and am running with no problem for the Router or the ApplicationRunner app

Was the Autobahn 0.13.0 installation an error?

Thanks,
Steve

0 Likes

#2

Hi Steve,

what installation method are you using? I just installed on a fresh Ubuntu (using pip) and I get version 0.13.0 for both Crossbar and Autobahn. Running one of the templates with this works fine.

Regards,

Alex

0 Likes

#3

I used the “pip update crossbar” command and got the crossbar/autobahn mismatch I showed. Maybe a mis-configuration in the Python package index has been repaired since yesterday, giving you consistent versions.

Thanks.

···

On Wednesday, March 16, 2016 at 8:33:59 AM UTC-7, Alexander Gödde wrote:

Hi Steve,

what installation method are you using? I just installed on a fresh Ubuntu (using pip) and I get version 0.13.0 for both Crossbar and Autobahn. Running one of the templates with this works fine.

Regards,

Alex

0 Likes

#4

I did the upgrade again - got consistent version for Crossbar and Autobahn this time (0.13.0). “Crossbar start” and “crossbar check” now yield that an upgrade to config file is needed, which “crossbar upgrade” will perform.

···

On Wednesday, March 16, 2016 at 10:20:41 AM UTC-7, Steve Ditlinger wrote:

I used the “pip update crossbar” command and got the crossbar/autobahn mismatch I showed. Maybe a mis-configuration in the Python package index has been repaired since yesterday, giving you consistent versions.

Thanks.

On Wednesday, March 16, 2016 at 8:33:59 AM UTC-7, Alexander Gödde wrote:

Hi Steve,

what installation method are you using? I just installed on a fresh Ubuntu (using pip) and I get version 0.13.0 for both Crossbar and Autobahn. Running one of the templates with this works fine.

Regards,

Alex

0 Likes

#5

Unfortunately the “crossbar upgrade” command creates an error in the config file, for which I will create a separate thread…

···

On Thursday, March 17, 2016 at 8:55:40 AM UTC-7, Steve Ditlinger wrote:

I did the upgrade again - got consistent version for Crossbar and Autobahn this time (0.13.0). “Crossbar start” and “crossbar check” now yield that an upgrade to config file is needed, which “crossbar upgrade” will perform.

On Wednesday, March 16, 2016 at 10:20:41 AM UTC-7, Steve Ditlinger wrote:

I used the “pip update crossbar” command and got the crossbar/autobahn mismatch I showed. Maybe a mis-configuration in the Python package index has been repaired since yesterday, giving you consistent versions.

Thanks.

On Wednesday, March 16, 2016 at 8:33:59 AM UTC-7, Alexander Gödde wrote:

Hi Steve,

what installation method are you using? I just installed on a fresh Ubuntu (using pip) and I get version 0.13.0 for both Crossbar and Autobahn. Running one of the templates with this works fine.

Regards,

Alex

0 Likes