Session timeouts for guest workers

#1

Hello All,

I was wondering if anyone knows how to set session timeouts for guest workers?

I can not find anything in the config for the router and this might be an autobahn question but I’m not sure (I imagine the router is handling session info).

What I have is an Authentication and Authorization guest worker that the router runs on start up. After some time (I leave the server up overnight) I will notice that subsequent calls to any registered procedure that worked before I “walked away” from the system the night before no longer work with a “no proc registered” error. I assume by looking at the session list on the router that at some point the sessions were closed due to inactivity.

Where are session timeouts configured? I need to configure Auth guest workers for infinite timeout…

Please and thank you :wink:

Dave

0 Likes

#2

Bumping this in hopes someone has an idea of how to accomplish this?

0 Likes

#3

Hi Dave!

AFAIK there are no session timeouts. WebSocket is intended for long-running connections, so there’s no reason to have one.

What we do have is an auto-ping timeout for the WebSocket connection, i.e. when you set auto-ping then this is the time without response after which the connection is assumed down.

My advice would be to start with the Authentication and Authorization worker and see whether there is anything that crashes this.

Regards,

Alex

···

Am Montag, 22. Juni 2015 22:05:55 UTC+2 schrieb Dave Thomas:

Bumping this in hopes someone has an idea of how to accomplish this?

0 Likes

#4

Hi Dave,

guest workers which connect via WAMP-over-WebSocket to a router worker are no different than any other WAMP-over-WebSocket client from a router standpoint. It’s just an incoming WebSocket connection.

Crossbar.io itself will not time out inactive WebSocket connections. We have timeout for initial WebSocket opening handshake and final closing handshake, but not in between. And we have WebSocket auto-ping-pong from keep intermediaries sitting between a WebSocket client (browser, guest worker, whatever) and a router worker from killing inactivate sessions.

All these options are documented here: http://crossbar.io/docs/WebSocket-Options/#available-options

Cheers,
/Tobias

···

Am Donnerstag, 30. April 2015 20:50:18 UTC+2 schrieb Dave Thomas:

Hello All,

I was wondering if anyone knows how to set session timeouts for guest workers?

I can not find anything in the config for the router and this might be an autobahn question but I’m not sure (I imagine the router is handling session info).

What I have is an Authentication and Authorization guest worker that the router runs on start up. After some time (I leave the server up overnight) I will notice that subsequent calls to any registered procedure that worked before I “walked away” from the system the night before no longer work with a “no proc registered” error. I assume by looking at the session list on the router that at some point the sessions were closed due to inactivity.

Where are session timeouts configured? I need to configure Auth guest workers for infinite timeout…

Please and thank you :wink:

Dave

0 Likes