Questions regarding migration of a WAMPv1 server

#1

Hi there, I currently have an Autobah-python running with Python autobahn 0.6.5. It uses a WampServerFactory with a WampCraServerProtocol and listens on port 9000. Clients connect to it directly, authenticate, and then use the endpoints. Now I would like to have a .NET application made and WampSharp only seems to work properly with WAMPv2. Can I use the new version of autobahn-python and make a server in the same way? Or do I need to install crossbar.io and use that? Thanks.

0 Likes

#2

Note that I am not opposed to installing crossbar.io; but time is a bit of an issue and I just want to make sure I am taking the shortest path to this migration.

···

On Friday, 21 September 2018 21:41:50 UTC-3, Malibu wrote:

Hi there, I currently have an Autobah-python running with Python autobahn 0.6.5. It uses a WampServerFactory with a WampCraServerProtocol and listens on port 9000. Clients connect to it directly, authenticate, and then use the endpoints. Now I would like to have a .NET application made and WampSharp only seems to work properly with WAMPv2. Can I use the new version of autobahn-python and make a server in the same way? Or do I need to install crossbar.io and use that? Thanks.

0 Likes

#3

Hi,

Hi there, I currently have an Autobah-python running with Python autobahn
0.6.5. It uses a WampServerFactory with a WampCraServerProtocol and
listens on port 9000. Clients connect to it directly, authenticate, and
then use the endpoints. Now I would like to have a .NET application made
and WampSharp only seems to work properly with WAMPv2. Can I use the new
version of autobahn-python and make a server in the same way? Or do I need
to install crossbar.io and use that? Thanks.

You will need a WAMP v2 router, like crossbar, yeah. the wampsharp
client will connect to that. any backend code that was previously ran
under autobahn 0.6.5: there will be some small code adjustments
necessary if you want to go to the current autobahn python version with
that. which you might want to as the old version does not (I think,
would need to look) support v2 of the WAMP protocol. and that autobahn
based client with your backend code would be the 2nd client besides the
wampsharp one.

So overall: some work, but straight forward ..

Hope this helps;)
/Tobias

···

Am 22.09.2018 um 02:41 schrieb Malibu:

0 Likes