Pusher configuration fails to start with 0.10.3

#1

Hi

After upgrading to 0.10.3 Crossbar won’t start with a previously working configuration

‘Exception: invalid type ‘pusher’ for sub-path service in Web transport path service’

Has the name of a pusher changed?

(When I remove the pusher configuration Crossbar starts fine)

{

“controller”: {

},

“workers”: [

{

“type”: “router”,

“realms”: [

{

“name”: “realm1”,

“roles”: [

{

“name”: “anonymous”,

“permissions”: [

{

“uri”: “*”,

“publish”: true,

“subscribe”: true,

“call”: true,

“register”: true

}

]

}

]

}

],

“transports”: [

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8090,

“tls”: {

“key”: “ssl/private/xxx.key”,

“certificate”: “ssl/certs/xxx.crt.chain”,

“dhparam”: “dhparam.pem”

}

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: true,

“debug”: false

}

}

}

},

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8091

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: false,

“debug”: false

}

}

}

}

]

}

]

}

``

0 Likes

#2

Hi Bas!

The pusherhas indeed been renamed. It’s now the “publisher”.

The reason for this is that we’re extending the REST capabilities of Crossbar.io. There’s now also a caller, and there’ll be ways to bridge the other WAMP roles (callee and subscriber) as well.

Regards,

Alex

···

Am Dienstag, 24. März 2015 14:04:49 UTC+1 schrieb Bas Kamer:

Hi

After upgrading to 0.10.3 Crossbar won’t start with a previously working configuration

‘Exception: invalid type ‘pusher’ for sub-path service in Web transport path service’

Has the name of a pusher changed?

(When I remove the pusher configuration Crossbar starts fine)

{

“controller”: {

},

“workers”: [

{

“type”: “router”,

“realms”: [

{

“name”: “realm1”,

“roles”: [

{

“name”: “anonymous”,

“permissions”: [

{

“uri”: “*”,

“publish”: true,

“subscribe”: true,

“call”: true,

“register”: true

}

]

}

]

}

],

“transports”: [

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8090,

“tls”: {

“key”: “ssl/private/xxx.key”,

“certificate”: “ssl/certs/xxx.crt.chain”,

“dhparam”: “dhparam.pem”

}

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: true,

“debug”: false

}

}

}

},

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8091

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: false,

“debug”: false

}

}

}

}

]

}

]

}

``

0 Likes

#3

ah that helps. thanks

···

Op woensdag 25 maart 2015 12:56:27 UTC+1 schreef Alexander Gödde:

Hi Bas!

The pusherhas indeed been renamed. It’s now the “publisher”.

The reason for this is that we’re extending the REST capabilities of Crossbar.io. There’s now also a caller, and there’ll be ways to bridge the other WAMP roles (callee and subscriber) as well.

Regards,

Alex

Am Dienstag, 24. März 2015 14:04:49 UTC+1 schrieb Bas Kamer:

Hi

After upgrading to 0.10.3 Crossbar won’t start with a previously working configuration

‘Exception: invalid type ‘pusher’ for sub-path service in Web transport path service’

Has the name of a pusher changed?

(When I remove the pusher configuration Crossbar starts fine)

{

“controller”: {

},

“workers”: [

{

“type”: “router”,

“realms”: [

{

“name”: “realm1”,

“roles”: [

{

“name”: “anonymous”,

“permissions”: [

{

“uri”: “*”,

“publish”: true,

“subscribe”: true,

“call”: true,

“register”: true

}

]

}

]

}

],

“transports”: [

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8090,

“tls”: {

“key”: “ssl/private/xxx.key”,

“certificate”: “ssl/certs/xxx.crt.chain”,

“dhparam”: “dhparam.pem”

}

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: true,

“debug”: false

}

}

}

},

{

“type”: “web”,

“endpoint”: {

“type”: “tcp”,

“port”: 8091

},

“paths”: {

“/”: {

“type”: “static”,

“directory”: “…/web/”

},

“ws”: {

“type”: “websocket”,

“debug”: false

},

“pushsigned”: {

“type”: “pusher”,

“realm”: “realm1”,

“role”: “anonymous”,

“options”: {

“key”: “xxx”,

“secret”: “xxx”,

“post_body_limit”: 8192,

“timestamp_delta_limit”: 30,

“require_tls”: false,

“debug”: false

}

}

}

}

]

}

]

}

``

0 Likes