Is Autobahn safe to use?

#1

Hi there. The website seems to be a mess of old versions and expired documentation. I would like to know if Autobahn is actually safe to use for production and if so, which versions?

For example, the latest git release of Autobahn Android is 0.5.1 which seems to add de.tavendo.autobahn.Wamp, but the download provided is for the 0.5.0 jar. There is no further documentation on which version is the stable one.

Most of the Python tutorials don’t work with the latest git version which is 0.5.14.

Please just tell me if Autobahn is ok to use and which versions… should I go by latest git release?

0 Likes

#2

For those who may be confused like me. I did the following to build android-autobahn 0.5.2 on mint:

apt-get install build-essential git maven
git clone https://github.com/tavendo/AutobahnAndroid.git
cd AutobahnAndroid
git checkout v.0.5.1
cd android

After doing all this I had a successful build. You will find the jar files in …/AutobahnAndroid/Autobahn/target. For some reason I got 0.5.2-SNAPSHOT files in the target dir rather than the 0.5.1 release. I renamed autobahn-android-0.5.2-SNAPSHOT.jar to autobahn-0.5.2.jar and put in in my project and it seems to be working better with the tutorials.

I wouldn’t mind updating the wiki if I understood things better, but I am a bit new to java and maven so I don’t feel I have the expertise to do so yet.

···

On Friday, August 23, 2013 3:50:47 PM UTC-5, jumb...@gmail.com wrote:

Hi there. The website seems to be a mess of old versions and expired documentation. I would like to know if Autobahn is actually safe to use for production and if so, which versions?

For example, the latest git release of Autobahn Android is 0.5.1 which seems to add de.tavendo.autobahn.Wamp, but the download provided is for the 0.5.0 jar. There is no further documentation on which version is the stable one.

Most of the Python tutorials don’t work with the latest git version which is 0.5.14.

Please just tell me if Autobahn is ok to use and which versions… should I go by latest git release?

0 Likes

#3

Hi there. The website seems to be a mess of old versions and expired

If you find bugs in the tutorials, website or documentation, please file issues on Github:

https://github.com/tavendo/AutobahnWebsite

documentation. I would like to know if Autobahn is actually safe to use
for production and if so, which versions?

AutobahnPython: v0.5.14 on PyPi and tagged on GitHub are very solid.
AutobahnJS: very solid. Use latest tagged version from GtiHub.
AutobahnAndroid: solid, but needs more love.

For example, the latest git release of Autobahn Android is 0.5.1 which
seems to add de.tavendo.autobahn.Wamp, but the download provided is for
the 0.5.0 jar. There is no further documentation on which version is
the stable one.

For AutobahnAndroid, please use the latest Git master (until someone takes care to finish the Maven stuff).

Most of the Python tutorials don't work with the latest git version
which is 0.5.14.

Which ones?

···

Am 23.08.2013 22:50, schrieb jumbo...@gmail.com:

Please just tell me if Autobahn is ok to use and which versions.. should
I go by latest git release?

--
You received this message because you are subscribed to the Google
Groups "Autobahn" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to autobahnws+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

0 Likes

#4

Thank you Tobias. You have given me some confidence. I will report bugs for the things I see that are wrong.

···

On Friday, August 23, 2013 3:50:47 PM UTC-5, jumb...@gmail.com wrote:

Hi there. The website seems to be a mess of old versions and expired documentation. I would like to know if Autobahn is actually safe to use for production and if so, which versions?

For example, the latest git release of Autobahn Android is 0.5.1 which seems to add de.tavendo.autobahn.Wamp, but the download provided is for the 0.5.0 jar. There is no further documentation on which version is the stable one.

Most of the Python tutorials don’t work with the latest git version which is 0.5.14.

Please just tell me if Autobahn is ok to use and which versions… should I go by latest git release?

0 Likes