Install from source error

#1

I’m trying to install Autobahn on Debian 3.1 from source. I get the following output when running python setup.py install

Are the errors related to the warnings at the top?
/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown distribution option: ‘zip_safe’

warnings.warn(msg)

/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown distribution option: ‘install_requires’

warnings.warn(msg)

running install

running build

running build_py

running install_lib

byte-compiling /usr/lib/python2.3/site-packages/autobahn/websocket.py to websocket.pyc

File “/usr/lib/python2.3/site-packages/autobahn/websocket.py”, line 210

class HttpException():

^

SyntaxError: invalid syntax

byte-compiling /usr/lib/python2.3/site-packages/autobahn/wamp.py to wamp.pyc

File “/usr/lib/python2.3/site-packages/autobahn/wamp.py”, line 571

finally:

^

SyntaxError: invalid syntax

0 Likes

#2

Python 2.3 is no longer supported .. neither by Autobahn nor by Twisted. Please upgrade to at least Python 2.6 ..

-- Tobias

···

Am 08.01.2013 16:58, schrieb Trendal Toews:

I'm trying to install Autobahn on Debian 3.1 from source. I get the
following output when running python setup.py install

Are the errors related to the warnings at the top?
/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown
distribution option: 'zip_safe'
   warnings.warn(msg)
/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown
distribution option: 'install_requires'
   warnings.warn(msg)
running install
running build
running build_py
running install_lib
byte-compiling /usr/lib/python2.3/site-packages/autobahn/websocket.py to
websocket.pyc
   File "/usr/lib/python2.3/site-packages/autobahn/websocket.py", line 210
     class HttpException():
                         ^
SyntaxError: invalid syntax
byte-compiling /usr/lib/python2.3/site-packages/autobahn/wamp.py to wamp.pyc
   File "/usr/lib/python2.3/site-packages/autobahn/wamp.py", line 571
     finally:
           ^
SyntaxError: invalid syntax

0 Likes

#3

Okay I will see if I can get 2.6 on this board.

···

On Tuesday, January 8, 2013 7:58:34 AM UTC-8, Trendal Toews wrote:

I’m trying to install Autobahn on Debian 3.1 from source. I get the following output when running python setup.py install

Are the errors related to the warnings at the top?
/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown distribution option: ‘zip_safe’

warnings.warn(msg)

/usr/lib/python2.3/distutils/dist.py:227: UserWarning: Unknown distribution option: ‘install_requires’

warnings.warn(msg)

running install

running build

running build_py

running install_lib

byte-compiling /usr/lib/python2.3/site-packages/autobahn/websocket.py to websocket.pyc

File “/usr/lib/python2.3/site-packages/autobahn/websocket.py”, line 210

class HttpException():

^

SyntaxError: invalid syntax

byte-compiling /usr/lib/python2.3/site-packages/autobahn/wamp.py to wamp.pyc

File “/usr/lib/python2.3/site-packages/autobahn/wamp.py”, line 571

finally:

^

SyntaxError: invalid syntax

0 Likes