Help | Configuring Manhole feature

#1

Hello,
I am developing an application using Crossbar router and need to allow SSH connection on it. I found the crossbar’s manhole feature is for allowing SSH on the node. So made some changes in configuration of crossbar node after I read the link http://crossbar.io/docs/Manhole/
Unfortunately, after making those changes the crossbar is getting shutdown as soon as I give command “crossbar start”. The logs shows the following errors :
2016-05-05T13:24:47+0530 [Controller 3757] Router with ID ‘worker-001’ and PID 3762 started
2016-05-05T13:24:47+0530 [Router 3762] ConchFactory starting on 6022
2016-05-05T13:24:47+0530 [Router 3762] Manhole service endpoint cannot listen: (‘no host keys, failing’, None)
2016-05-05T13:24:47+0530 [Router 3762] NativeWorkerSession.onUserError
2016-05-05T13:24:47+0530 [Controller 3757] crossbar.error.cannot_listen: Manhole service endpoint cannot listen: (‘no host keys, failing’, None)
2016-05-05T13:24:47+0530 [Controller 3757] sending TERM to subprocess 3762
2016-05-05T13:24:47+0530 [Controller 3757] waiting for 3762 to exit…
2016-05-05T13:24:47+0530 [Router 3762] Native worker received SIGTERM - shutting down …
2016-05-05T13:24:47+0530 [Router 3762] Shutdown of worker requested!
2016-05-05T13:24:47+0530 [Router 3762] Connection to node controller closed cleanly
2016-05-05T13:24:47+0530 [Controller 3757] Native worker connection closed cleanly.
2016-05-05T13:24:47+0530 [Controller 3757] Node worker worker-001 ended successfully
2016-05-05T13:24:47+0530 [Controller 3757] Node worker ended, and trigger ‘shutdown_on_worker_exit’ active
2016-05-05T13:24:47+0530 [Controller 3757] Node shutting down …
2016-05-05T13:24:47+0530 [Controller 3757] Shutting down node…

The config.json file contents following configuration:
{
“version”: 2,
“controller”: {},
“workers”: [
{
“type”: “router”,
“manhole”: {
“endpoint”: {
“type”: “tcp”,
“port”: 6022,
“interface”: “192.168.1.79”
},
“users”: [
{
“user”: “vaibhav”,
“password”: “asm532”
}
]
},
“realms”: [
{
“name”: “Router1”,
“roles”: [
{
“name”: “anonymous”,
“permissions”: [
{
“uri”: “”,
“match”: “prefix”,
“allow”: {
“call”: true,
“register”: true,
“publish”: true,
“subscribe”: true
},
“disclose”: {
“caller”: false,
“publisher”: false
},
“cache”: true
}
]
}
]
}
],
“transports”: [
{
“type”: “websocket”,
“endpoint”: {
“type”: “tcp”,
“port”: 8080
},
“url”: “ws://192.168.1.79:8080”,
“options”: {
“enable_webstatus”: false,
“max_frame_size”: 1048576,
“max_message_size”: 1048576,
“auto_fragment_size”: 65536,
“fail_by_drop”: true,
“open_handshake_timeout”: 2500,
“close_handshake_timeout”: 1000,
“auto_ping_interval”: 10000,
“auto_ping_timeout”: 5000,
“auto_ping_size”: 4
}
}
]
}
]
}

Can anyone please suggest what causing this issue or any direction how to configure manhole feature?

Thanks,
Vaibhav

0 Likes