File upload service

#1

Hi,

I’ve just started trying to use the new file upload service using 0.11.1 and I seem to be having an issue. I’ve pasted the following into my config.json from the examples;

“upload”: {
“type” : “upload”,
“realm” : “ionman”,
“role” : “anonymous”,
“directory” : “/tmp”,
“temp_directory”: “/tmp”,
“form_fields” : {
“file_name”: “upFilename”,
“mime_type”: “upMimetype”,
“total_size”: “upTotalsize”,
“total_chunks”: “upChunks”,
“chunk_size”: “upChunkSize”,
“chunk_number”: “upChunkNumber”,
“content”: “upFilename”,
“on_progress”: “on_progress”,
“session”: “session”
},
“options”: {
“max_file_size”: 209715200,
“file_permissions”: “0644”,
“file_types”: [".csv", “.txt”, “.pdf”, “.img”]
}

``

But when I start crossbar now I see;

crossbar.router.router.Router] Validate ‘call_error’ for ‘crossbar.node. … .worker.worker1.start_router_transport’
crossbar.controller.cli.run_command_start] Could not start node: ‘int’ object has no attribute ‘strip’

``

I’m guessing something in my config is wrong or out of date … anything jump out as obvious?

(crossbar check validates the config Ok …)

If I remove the section above, crossbar starts and runs fine …

??

0 Likes

#2

Ok, found it, the problem is caused by setting “temp_directory” to be the same as “directory” … setting “temp_directory” to “/tmp/xx” fixes it …

Bug?

0 Likes