exceptions.TypeError: Data must not be unicode

#1

Hi i tried the python websockets tutorial given here:
http://www.tavendo.de/autobahn/tutorial/echo.html

ther server runs fine but whenever i try to access it through browser
it gives this message and nothin heppens.

Please help me here

Thanks in advance,
Abhishek bajpai

0 Likes

#2

Its working from the git repo where you have changed
<reactor.listenTCP(9000, factory)> with <listenWS(factory)> please fix
it there also

···

On Nov 7, 5:39 pm, Abhishek Bajpai <abhi...@gmail.com> wrote:

Hi i tried the python websockets tutorial given here:http://www.tavendo.de/autobahn/tutorial/echo.html

ther server runs fine but whenever i try to access it through browser
it gives this message and nothin heppens.

Please help me here

Thanks in advance,
Abhishek bajpai

0 Likes

#3

yeah, sorry .. its a documentation bug

https://github.com/oberstet/Autobahn/issues/77

···

On Nov 7, 1:51 pm, Abhishek Bajpai <abhi...@gmail.com> wrote:

Its working from the git repo where you have changed
<reactor.listenTCP(9000, factory)> with <listenWS(factory)> please fix
it there also

On Nov 7, 5:39 pm, Abhishek Bajpai <abhi...@gmail.com> wrote:

> Hi i tried the python websockets tutorial given here:http://www.tavendo.de/autobahn/tutorial/echo.html

> ther server runs fine but whenever i try to access it through browser
> it gives this message and nothin heppens.

> Please help me here

> Thanks in advance,
> Abhishek bajpai

0 Likes

#4

Isn’t the fact that it’s trying to write unicode into the transport also a bug?

0 Likes