Crossbar working on Raspberry 3?

#1

Hi,

I just tried to run Crossbar 0.12.1 on Raspberry 3 but it does not start up… Not even the crossbar init example

It worked fine on rasp2. Any hints on what could be wrong?

2016-03-17T21:09:48+0000 [Controller 2965] Automatically choosing optimal Twisted reactor

2016-03-17T21:09:48+0000 [Controller 2965] Running on Linux and optimal reactor (epoll) was installed.

2016-03-17T21:09:51+0000 [Controller 2965] __ __ __ __ __ __ __ __

2016-03-17T21:09:51+0000 [Controller 2965] */ |__)/ \/__/`|) /\ |__) |/ *

2016-03-17T21:09:51+0000 [Controller 2965] _,| \/././|)/~~| . |_/

2016-03-17T21:09:51+0000 [Controller 2965] ****

2016-03-17T21:09:51+0000 [Controller 2965] Crossbar.io Version: 0.12.1

2016-03-17T21:09:51+0000 [Controller 2965] Node Public Key: 462de27dfcecd201d94f6d5c0ca7ea0f5a2fecdc1b3063e7161948b1e490f325

2016-03-17T21:09:51+0000 [Controller 2965]

2016-03-17T21:09:51+0000 [Controller 2965] Running from node directory ‘/root/.crossbar’

2016-03-17T21:09:51+0000 [Controller 2965] Controller process starting (CPython-EPollReactor) …

2016-03-17T21:09:51+0000 [Controller 2965] Node configuration loaded from ‘config.json’

2016-03-17T21:09:51+0000 [Controller 2965] Node ID ‘raspberrypi3-334398’ set from hostname

2016-03-17T21:09:51+0000 [Controller 2965] Using default node shutdown triggers [u’shutdown_on_worker_exit’]

2016-03-17T21:09:51+0000 [Controller 2965]

2016-03-17T21:09:51+0000 [Controller 2965] Could not start node

Here are my dependencies

attrs (15.2.0)

autobahn (0.13.0)

bzr (2.7.0.dev1)

cbor (1.0.0)

cffi (1.5.2)

chardet (2.3.0)

click (6.3)

colorama (0.3.2)

configobj (5.0.6)

crossbar (0.12.1)

cryptography (1.2.3)

enum34 (1.1.2)

html5lib (0.999)

idna (2.0)

ipaddress (1.0.16)

Jinja2 (2.8)

lmdb (0.89)

MarkupSafe (0.23)

mercurial (3.1.2)

mistune (0.7.2)

msgpack-python (0.4.7)

netaddr (0.7.18)

pip (8.1.1)

psutil (4.1.0)

pyasn1 (0.1.9)

pyasn1-modules (0.0.8)

pycparser (2.14)

Pygments (2.1.3)

pyinotify (0.9.6)

PyNaCl (1.0.1)

pyOpenSSL (0.15.1)

PyTrie (0.2)

PyYAML (3.11)

requests (2.9.1)

service-identity (16.0.0)

setproctitle (1.1.9)

setuptools (20.3)

shutilwhich (1.1.0)

six (1.10.0)

treq (15.1.0)

Twisted (16.0.0)

txaio (2.2.2)

ujson (1.35)

urllib3 (1.9.1)

wheel (0.29.0)

wsaccel (0.6.2)

zope.interface (4.1.3)

0 Likes

#2

Hi Tobias!

Looking at the log, your Autobahn and Crossbar versions are not matching. Try to re-download and install - we had a bit of a hiccup with non-synchronous updates of Autobahn and Crossbar a couple of days ago, and it’s entirely possible that your problems are down to this.

Regards,

Alex

···

Am Donnerstag, 17. März 2016 22:15:54 UTC+1 schrieb Tobias Lang:

Hi,

I just tried to run Crossbar 0.12.1 on Raspberry 3 but it does not start up… Not even the crossbar init example

It worked fine on rasp2. Any hints on what could be wrong?

2016-03-17T21:09:48+0000 [Controller 2965] Automatically choosing optimal Twisted reactor

2016-03-17T21:09:48+0000 [Controller 2965] Running on Linux and optimal reactor (epoll) was installed.

2016-03-17T21:09:51+0000 [Controller 2965] __ __ __ __ __ __ __ __

2016-03-17T21:09:51+0000 [Controller 2965] */ |__)/ \/__/`|) /\ |__) |/ *

2016-03-17T21:09:51+0000 [Controller 2965] _,| \/././|)/~~| . |_/

2016-03-17T21:09:51+0000 [Controller 2965] ****

2016-03-17T21:09:51+0000 [Controller 2965] Crossbar.io Version: 0.12.1

2016-03-17T21:09:51+0000 [Controller 2965] Node Public Key: 462de27dfcecd201d94f6d5c0ca7ea0f5a2fecdc1b3063e7161948b1e490f325

2016-03-17T21:09:51+0000 [Controller 2965]

2016-03-17T21:09:51+0000 [Controller 2965] Running from node directory ‘/root/.crossbar’

2016-03-17T21:09:51+0000 [Controller 2965] Controller process starting (CPython-EPollReactor) …

2016-03-17T21:09:51+0000 [Controller 2965] Node configuration loaded from ‘config.json’

2016-03-17T21:09:51+0000 [Controller 2965] Node ID ‘raspberrypi3-334398’ set from hostname

2016-03-17T21:09:51+0000 [Controller 2965] Using default node shutdown triggers [u’shutdown_on_worker_exit’]

2016-03-17T21:09:51+0000 [Controller 2965]

2016-03-17T21:09:51+0000 [Controller 2965] Could not start node

Here are my dependencies

attrs (15.2.0)

autobahn (0.13.0)

bzr (2.7.0.dev1)

cbor (1.0.0)

cffi (1.5.2)

chardet (2.3.0)

click (6.3)

colorama (0.3.2)

configobj (5.0.6)

crossbar (0.12.1)

cryptography (1.2.3)

enum34 (1.1.2)

html5lib (0.999)

idna (2.0)

ipaddress (1.0.16)

Jinja2 (2.8)

lmdb (0.89)

MarkupSafe (0.23)

mercurial (3.1.2)

mistune (0.7.2)

msgpack-python (0.4.7)

netaddr (0.7.18)

pip (8.1.1)

psutil (4.1.0)

pyasn1 (0.1.9)

pyasn1-modules (0.0.8)

pycparser (2.14)

Pygments (2.1.3)

pyinotify (0.9.6)

PyNaCl (1.0.1)

pyOpenSSL (0.15.1)

PyTrie (0.2)

PyYAML (3.11)

requests (2.9.1)

service-identity (16.0.0)

setproctitle (1.1.9)

setuptools (20.3)

shutilwhich (1.1.0)

six (1.10.0)

treq (15.1.0)

Twisted (16.0.0)

txaio (2.2.2)

ujson (1.35)

urllib3 (1.9.1)

wheel (0.29.0)

wsaccel (0.6.2)

zope.interface (4.1.3)

0 Likes