Crossbar upgrade command (0.13.0) creates error in config

#1

Upon upgrading crossbar versions (using pip) to version 0.13.0, I get a warning that my config file is obsolete, and to use “crossbar upgrade” to revise my config file. After doing that, Crossbar still will not start saying that I cannot combine “permissions” with “authorizer”. Inspection of config file leads to discovery that “crossbar upgrade” has added a “permissions” section to role definitions where an “authorizer” was already specified.

Removing the “permissions” section fixes the problem.

0 Likes

#2

Yeah, I had to backtrack to 0.12 too … tried a few iterations of trying to fix the problems described but ran out of time …

0 Likes