crossbar-postgres plugin: has the name changed for pip? (moved from autobahn)

#1

Hi all,

By the way, thanks for a very useful tool crossbar/wamp/autobahn!

I’m trying to work with crossbar-postgres natively and noted that Tobias is authoring it at github.com/crossbario/crossbar-postgres. I’ve followed the instructions until the following:

pip install crossbar-postgres

Pypi doesn’t show this wheel package or anything similar.

I realize that this project is early days with one author at the moment and I know you’re busy! However I’m so excited to try to make postgres work natively with crossbar, I wonder if you could point me to the plug in if it exists somewhere.

I’m familiar with the python-postgres implementation so I guessed the native version will use the HTML bridge (dblink) and a few other bells and whistles to avoid having to use a cursor, and that I’d simply call the stored procedures all from within index.html without having to edit a python file at all (bypassing it). Hope I’ve understood the intent as that sounds so efficient. In case that is the strategy, I’ve written all my stored procedures to return JSONB objects, as suggested in the docs.

Any help or suggestions of where to look to get it up and running would be welcome.

0 Likes

#2

More of an update than an answer, but thought I’d post more info after further research in case it helps others: although the github link I first posted above seems newer (few months old and mentions postgresql 9.5 which is current and has jsonb operators and functions not in 9.4 and mentioned as required by crossbar), I followed a crossbar doc here http://crossbar.io/docs/PostgreSQL-Integration/
to find:


pip install crossbar[postgres]

which worked OK even though that page mentions postgres 9.4 which importantly does not have the newer jsonb functions and operators referred to in the newer github link I posted first.

I haven’t had this confirmed, but my guess is that the [postgres] flag/option should makes it unnecessary to need pip install crossbar-postgres and that’s why the package was removed from pypi?

I then went to this github link https://github.com/crossbario/crossbarexamples/tree/master/database/postgresql

which also appears older than the first github link, but I was able to follow it to make and install the html extension to postgres9.5 and tested it OK.

Regards, -a

···

On Friday, September 30, 2016 at 7:43:54 PM UTC-4, Antony Mott wrote:

Hi all,

By the way, thanks for a very useful tool crossbar/wamp/autobahn!

I’m trying to work with crossbar-postgres natively and noted that Tobias is authoring it at github.com/crossbario/crossbar-postgres. I’ve followed the instructions until the following:

pip install crossbar-postgres

Pypi doesn’t show this wheel package or anything similar.

I realize that this project is early days with one author at the moment and I know you’re busy! However I’m so excited to try to make postgres work natively with crossbar, I wonder if you could point me to the plug in if it exists somewhere.

I’m familiar with the python-postgres implementation so I guessed the native version will use the HTML bridge (dblink) and a few other bells and whistles to avoid having to use a cursor, and that I’d simply call the stored procedures all from within index.html without having to edit a python file at all (bypassing it). Hope I’ve understood the intent as that sounds so efficient. In case that is the strategy, I’ve written all my stored procedures to return JSONB objects, as suggested in the docs.

Any help or suggestions of where to look to get it up and running would be welcome.

0 Likes