Crossbar on Cloud9 (c9.io)

#1

Hi Chris,

Anyone here running Crossbar on Cloud9? The crossbar server starts fine
and says it is running on port 8080 (I have tried various configurations
binding to 0.0.0.0 and 127.0.0.1), but I can't connect from a local Node

I'd try with the default config:

crossbar init

which will listen on HTTP/8080 (and not bind to a specific interface).

guest worker process with Autobahn. It just keeps saying the server is
'unreachable' using connection strings including "ws://0.0.0.0:8080/ws"
and "ws://127.0.0.1:8080/ws".

Can you invoke something like

wget http://127.0.0.1:8080

from within the c9 environment?

The correct URL for WebSocket with the default config and for use with components that are hosted on the same host as Crossbar.io is

ws://127.0.0.1:8080/ws

Any configuration tips?

c9 seems to be a PaaS platform. I have no clue about how c9 limits network capabilities of hosted apps. It has to somehow, for security reasons.

I'd expect at least loopback TCP to work without restrictions.

You could also try binding to a specific interface, like loopback-only:

                "endpoint": {
                   "type": "tcp",
                   "port": 8080,
                   "interface": "127.0.0.1"
                },

This will make Crossbar.io accept connections only coming over the loopback-interface (the interface bound to 127.0.0.1).

Binding to "0.0.0.0" will make it listen on all IPv4 addresses.

You could also try using Unix domain sockets as transport for the components talking to the router instead of loopback TCP - if the client library for WAMP supports that.

For the Autobahn's, only AutobahnPython has that. What language are your components?

Hope this helps,
/Tobias

···

Am 22.12.2015 um 13:46 schrieb Chris Beckett:

--
You received this message because you are subscribed to the Google
Groups "Crossbar" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to crossbario+...@googlegroups.com
<mailto:crossbario+...@googlegroups.com>.
To post to this group, send email to cross...@googlegroups.com
<mailto:cross...@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/crossbario/d05096e0-5317-4c65-912d-5d7174328050%40googlegroups.com
<https://groups.google.com/d/msgid/crossbario/d05096e0-5317-4c65-912d-5d7174328050%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.

0 Likes

#2

Hey Tobias,

I appreciate the response. I finally got it working when I just tried the default NodeJS:Hello template sample and it worked. So then I started comparing the sample config file to my own and figured out what I was doing wrong. I think it ended up being a conflict between a HTTP call bridge configured for anonymous and the web socket configured for authentication. I switched my transports around and got it working.

···

On Wednesday, December 23, 2015 at 1:47:59 AM UTC-8, Tobias Oberstein wrote:

Hi Chris,

Am 22.12.2015 um 13:46 schrieb Chris Beckett:

Anyone here running Crossbar on Cloud9? The crossbar server starts fine

and says it is running on port 8080 (I have tried various configurations

binding to 0.0.0.0 and 127.0.0.1), but I can’t connect from a local Node

I’d try with the default config:

crossbar init

which will listen on HTTP/8080 (and not bind to a specific interface).

guest worker process with Autobahn. It just keeps saying the server is

‘unreachable’ using connection strings including “ws://0.0.0.0:8080/ws

and “ws://127.0.0.1:8080/ws”.

Can you invoke something like

wget http://127.0.0.1:8080

from within the c9 environment?

The correct URL for WebSocket with the default config and for use with
components that are hosted on the same host as Crossbar.io is

ws://127.0.0.1:8080/ws

Any configuration tips?

c9 seems to be a PaaS platform. I have no clue about how c9 limits
network capabilities of hosted apps. It has to somehow, for security
reasons.

I’d expect at least loopback TCP to work without restrictions.

You could also try binding to a specific interface, like loopback-only:

            "endpoint": {

               "type": "tcp",

               "port": 8080,

               "interface": "127.0.0.1"

            },

This will make Crossbar.io accept connections only coming over the
loopback-interface (the interface bound to 127.0.0.1).

Binding to “0.0.0.0” will make it listen on all IPv4 addresses.

You could also try using Unix domain sockets as transport for the
components talking to the router instead of loopback TCP - if the client
library for WAMP supports that.

For the Autobahn’s, only AutobahnPython has that. What language are your
components?

Hope this helps,

/Tobias

You received this message because you are subscribed to the Google

Groups “Crossbar” group.

To unsubscribe from this group and stop receiving emails from it, send

an email to crossbario+...@googlegroups.com

mailto:crossbario+unsub...@googlegroups.com.

To post to this group, send email to cros...@googlegroups.com

mailto:cross...@googlegroups.com.

To view this discussion on the web visit

https://groups.google.com/d/msgid/crossbario/d05096e0-5317-4c65-912d-5d7174328050%40googlegroups.com

<https://groups.google.com/d/msgid/crossbario/d05096e0-5317-4c65-912d-5d7174328050%40googlegroups.com?utm_medium=email&utm_source=footer>.

For more options, visit https://groups.google.com/d/optout.

0 Likes