crossbar demos do not install (Windows7)

#1

Hello,

I am new to crossbario, and to Python too, but trying to evaluate it by
trying to get the crossbardemos working on my local machine running Windows 7(32bit).
I can get the demos working that come with crossbar.io (eg hello), but the installation crossbardemo
doesn’t seem to work.

I downloaded the zip from https://github.com/crossbario/crossbardemo, unzipped it and ran “python setup.py install”, which
threw up “warning: no files found matching ‘*’ under directory ‘crossbardemo\web’”.
I think that’s a simple type in the installer, so I copied the web folder from the top level into the crossbardemo top level folder,
deleted the partial installation, and started again from a freshly unzipped crossbardemo-master.zip.
This time the setup was much longer and no warnings were issued as far as I can see.
However, although this creates a subdir \Python27…\site-packages\crossbardemo-VERSION-py2.7.egg, there is
no subdir \Python27…\site-packages\crossbardemo created, nor are there any additional templates created in the
crossbar templates folder.

Hence,
crossbar init --template demos
fails with
"Exception: no node template '‘demos’…
and my ‘demo1’ directory remains empty.

I have also tried
pip install crossbardemo
but with the same result.

What am I doing wrong ?

Thanks

0 Likes

#2

that is the right way. pls append the log output if this command does not work for you.

···

Am 17.07.2014 17:43, schrieb tim.in...@gmail.com:

pip install crossbardemo

0 Likes

#3

Hello Tobias,

Thanks for your prompt reply.

I ran …
pip install crossbardemo > cbd_log.txt
and that log file is attached here.

That creates two folders…
crossbardemo
crossbardemo-0.3.3_2-py2.7.egg-info
under
\Python27\Lib\site-packages

However, no extra templates are installed under
\Python27\Lib\site-packages\crossbar\templates

and the crossbar init command generates this output…
C:\Users\TimI\demo1>crossbar init --template demos
Traceback (most recent call last):
File “D:\Apps\Python27\Scripts\crossbar-script.py”, line 9, in
load_entry_point(‘crossbar==0.9.7-2’, ‘console_scripts’, ‘crossbar’)()
File “D:\Apps\Python27\lib\site-packages\crossbar\controller\cli.py”, line 374
, in run
options.func(options)
File “D:\Apps\Python27\lib\site-packages\crossbar\controller\cli.py”, line 128
, in run_command_init
raise Exception(“no node template ‘{}’ - use the command 'crossbar templates
’ to list templates available”.format(options.template))
Exception: no node template ‘demos’ - use the command ‘crossbar templates’ to li
st templates available

Regards,
Tim

cbd_log.txt (1.86 KB)

···

On Thursday, 17 July 2014 16:43:21 UTC+1, tim....@gmail.com wrote:

Hello,

I am new to crossbario, and to Python too, but trying to evaluate it by
trying to get the crossbardemos working on my local machine running Windows 7(32bit).
I can get the demos working that come with crossbar.io (eg hello), but the installation crossbardemo
doesn’t seem to work.

I downloaded the zip from https://github.com/crossbario/crossbardemo, unzipped it and ran “python setup.py install”, which
threw up “warning: no files found matching ‘*’ under directory ‘crossbardemo\web’”.
I think that’s a simple type in the installer, so I copied the web folder from the top level into the crossbardemo top level folder,
deleted the partial installation, and started again from a freshly unzipped crossbardemo-master.zip.
This time the setup was much longer and no warnings were issued as far as I can see.
However, although this creates a subdir \Python27…\site-packages\crossbardemo-VERSION-py2.7.egg, there is
no subdir \Python27…\site-packages\crossbardemo created, nor are there any additional templates created in the
crossbar templates folder.

Hence,
crossbar init --template demos
fails with
"Exception: no node template '‘demos’…
and my ‘demo1’ directory remains empty.

I have also tried
pip install crossbardemo
but with the same result.

What am I doing wrong ?

Thanks

0 Likes

#4

Hi Tim,

sorry for the delay. There was a regression

https://github.com/crossbario/crossbar/issues/95

that I just fixed. Please update Crossbar by doing

pip install -U crossbar

Then you can create a node running the demos by doing

crossbar init --template demos
crossbar start

Please see the log below. That is on Windows.

Could you check if that works for you?

/Tobias

oberstet@THINKPAD-T410S /c/Temp
$ crossbar init --template demos
Initializing application template 'demos' in directory 'c:\Temp'
Using templates from 'c:/Python27/lib/site-packages/crossbar-0.9.7_3-py2.7.egg/crossbar/templates/demos'
Creating directory c:\Temp\.crossbar
Creating file c:\Temp\.crossbar\config.json
Application template initialized

To start your node, run 'crossbar start --cbdir c:\Temp\.crossbar'

oberstet@THINKPAD-T410S /c/Temp
$ crossbar start
2014-07-23 17:16:43+0200 [Controller 7428] Log opened.
2014-07-23 17:16:43+0200 [Controller 7428] ============================== Crossbar.io ==============================

2014-07-23 17:16:43+0200 [Controller 7428] Crossbar.io 0.9.7-3 starting
2014-07-23 17:16:45+0200 [Controller 7428] Running on CPython using IOCPReactor reactor
2014-07-23 17:16:45+0200 [Controller 7428] Starting from node directory c:\Temp\.crossbar
2014-07-23 17:16:45+0200 [Controller 7428] Starting from local configuration 'c:\Temp\.crossbar\config.json'
2014-07-23 17:16:45+0200 [Controller 7428] Warning, could not set process title (setproctitle not installed)
2014-07-23 17:16:45+0200 [Controller 7428] No WAMPlets detected in enviroment.
2014-07-23 17:16:45+0200 [Controller 7428] Starting Router with ID 'worker1' ..
2014-07-23 17:16:46+0200 [Router 8344] Log opened.
2014-07-23 17:16:46+0200 [Router 8344] Warning: could not set worker process title (setproctitle not installed)
2014-07-23 17:16:47+0200 [Router 8344] Running under CPython using IOCPReactor reactor
2014-07-23 17:16:48+0200 [Router 8344] Entering event loop ..
2014-07-23 17:16:48+0200 [Controller 7428] Router with ID 'worker1' and PID 8344 started
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': realm 'realm1' started
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': role 'role1' started on realm 'realm1'
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': component 'component1' started
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': component 'component2' started
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': component 'component3' started
2014-07-23 17:16:48+0200 [Router 8344] Loaded static Web resource 'web' from package 'crossbardemo 0.3.3-2' (filesystem path c:\Python
27\lib\site-packages\crossbardemo\web)
2014-07-23 17:16:48+0200 [Router 8344] Site starting on 8080
2014-07-23 17:16:48+0200 [Controller 7428] Router 'worker1': transport 'transport1' started

···

Am 18.07.2014 10:06, schrieb tim.in...@gmail.com:

Hello Tobias,

Thanks for your prompt reply.

I ran ..
pip install crossbardemo > cbd_log.txt
and that log file is attached here.

That creates two folders..
crossbardemo
crossbardemo-0.3.3_2-py2.7.egg-info
under
\Python27\Lib\site-packages

However, no extra templates are installed under
\Python27\Lib\site-packages\crossbar\templates

and the crossbar init command generates this output..
C:\Users\TimI\demo1>crossbar init --template demos
Traceback (most recent call last):
   File "D:\Apps\Python27\Scripts\crossbar-script.py", line 9, in <module>
     load_entry_point('crossbar==0.9.7-2', 'console_scripts', 'crossbar')()
   File "D:\Apps\Python27\lib\site-packages\crossbar\controller\cli.py",
line 374
, in run
     options.func(options)
   File "D:\Apps\Python27\lib\site-packages\crossbar\controller\cli.py",
line 128
, in run_command_init
     raise Exception("no node template '{}' - use the command 'crossbar
templates
' to list templates available".format(options.template))
Exception: no node template 'demos' - use the command 'crossbar
templates' to li
st templates available

Regards,
Tim

On Thursday, 17 July 2014 16:43:21 UTC+1, tim....@gmail.com wrote:

    Hello,

    I am new to crossbario, and to Python too, but trying to evaluate it by
    trying to get the crossbardemos working on my local machine running
    Windows 7(32bit).
    I can get the demos working that come with crossbar.io
    <http://crossbar.io> (eg hello), but the installation crossbardemo
    doesn't seem to work.

    I downloaded the zip from https://github.com/crossbario/crossbardemo
    <https://github.com/crossbario/crossbardemo>, unzipped it and ran
    "python setup.py install", which
    threw up "warning: no files found matching '*' under directory
    'crossbardemo\web'".
    I think that's a simple type in the installer, so I copied the web
    folder from the top level into the crossbardemo top level folder,
    deleted the partial installation, and started again from a freshly
    unzipped crossbardemo-master.zip.
    This time the setup was much longer and no warnings were issued as
    far as I can see.
    However, although this creates a subdir
    \Python27\...\site-packages\crossbardemo-_VERSION_-py2.7.egg, there is
    no subdir \Python27\...\site-packages\crossbardemo created, nor are
    there any additional templates created in the
    crossbar templates folder.

    Hence,
    crossbar init --template demos
    fails with
    "Exception: no node template ''demos'...
    and my 'demo1' directory remains empty.

    I have also tried
    pip install crossbardemo
    but with the same result.

    What am I doing wrong ?

    Thanks

--
You received this message because you are subscribed to the Google
Groups "Autobahn" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to autobahnws+...@googlegroups.com
<mailto:autobahnws+...@googlegroups.com>.
To post to this group, send email to autob...@googlegroups.com
<mailto:autob...@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/autobahnws/924e101f-67c9-49f6-982a-a1dd7d765236%40googlegroups.com
<https://groups.google.com/d/msgid/autobahnws/924e101f-67c9-49f6-982a-a1dd7d765236%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.

0 Likes

#5

Hi Tobias,

That’s fixed it, all the demos work now.

Many thanks !
Tim

···

On Thursday, 17 July 2014 16:43:21 UTC+1, tim....@gmail.com wrote:

Hello,

I am new to crossbario, and to Python too, but trying to evaluate it by
trying to get the crossbardemos working on my local machine running Windows 7(32bit).
I can get the demos working that come with crossbar.io (eg hello), but the installation crossbardemo
doesn’t seem to work.

I downloaded the zip from https://github.com/crossbario/crossbardemo, unzipped it and ran “python setup.py install”, which
threw up “warning: no files found matching ‘*’ under directory ‘crossbardemo\web’”.
I think that’s a simple type in the installer, so I copied the web folder from the top level into the crossbardemo top level folder,
deleted the partial installation, and started again from a freshly unzipped crossbardemo-master.zip.
This time the setup was much longer and no warnings were issued as far as I can see.
However, although this creates a subdir \Python27…\site-packages\crossbardemo-VERSION-py2.7.egg, there is
no subdir \Python27…\site-packages\crossbardemo created, nor are there any additional templates created in the
crossbar templates folder.

Hence,
crossbar init --template demos
fails with
"Exception: no node template '‘demos’…
and my ‘demo1’ directory remains empty.

I have also tried
pip install crossbardemo
but with the same result.

What am I doing wrong ?

Thanks

0 Likes

#6

Some really cool demos, BTW !

0 Likes