Contoller's option "shutdown" does not work

#1

Dear Colleagues,

during my experiments with Crossbar I found out the following issue. I am trying to make controller stop when guest process finishes. For this purpose I use the following configuration:

version: 2
controller:
options:
shutdown: [shutdown_on_worker_exit, shutdown_on_worker_exit_with_error, shutdown_on_last_worker_exit]
workers:

  • type: guest
    executable: “python”
    arguments: ["…/da/p7app/serv.py"]

file serv.py is the following:

from time import sleep
from os import getpid
print(getpid(), “: I am started”)
sleep(3)

What I am doing wrong?

0 Likes