can i use android v1 with latest version of crossbar?

#1

I want use android authoban, Can i use android client with latest version crossbar and other client that are compatible with wamp2?

can i mix various client versions?

what is difference between wamp 1 and wamp 2?

what no want work in this way?

0 Likes

#2

Hi Mohammad!

WAMP v1 and WAMP v2 are incompatible. Since AutobahnAndroid is still at WAMP v1, you cannot use it with Crossbar.io.

WAMP v1 and WAMP v2 are different in many respects, e.g. in v2 you have routed RPCs.

If you want to use WAMP v2 under Android, then take a look at https://github.com/Vinelab/Android-wamp-client

Regards,

Alex

···

Am Mittwoch, 30. Dezember 2015 14:43:00 UTC+1 schrieb mohammad ghanbari:

I want use android authoban, Can i use android client with latest version crossbar and other client that are compatible with wamp2?

can i mix various client versions?

what is difference between wamp 1 and wamp 2?

what no want work in this way?

0 Likes

#3

Hi Alexandger,

I have Used the v2 with android but there is one issue on lolipop it’s working fine whilw in the case of Kitkat some of the jars are not loading and throws Noclass def error on runtime. Please help

···

On Wednesday, January 13, 2016 at 5:16:57 PM UTC+5:30, Alexander Gödde wrote:

Hi Mohammad!

WAMP v1 and WAMP v2 are incompatible. Since AutobahnAndroid is still at WAMP v1, you cannot use it with Crossbar.io.

WAMP v1 and WAMP v2 are different in many respects, e.g. in v2 you have routed RPCs.

If you want to use WAMP v2 under Android, then take a look at https://github.com/Vinelab/Android-wamp-client

Regards,

Alex

Am Mittwoch, 30. Dezember 2015 14:43:00 UTC+1 schrieb mohammad ghanbari:

I want use android authoban, Can i use android client with latest version crossbar and other client that are compatible with wamp2?

can i mix various client versions?

what is difference between wamp 1 and wamp 2?

what no want work in this way?

0 Likes