Autobahn TestSuite connection problems with jWebSocket server

#1

Hi,

I
am trying to use the Autobahn TestSuite python library to test my jWebSocket
server deployment on Ubuntu machine but keep getting a failed connection
message of the following type from my jWebSocket server:

ERROR

  • TCPConnector$ClientProcessor: Client not accepted on port XXXXX due to
    handshake issues.

I
followed the jWebSocket documentation regarding setting empty or null domain
but with no help.

I
wrote a small java websocket client based on async-http-client java library and
it seems to connect with no problem to the server and the messages I am sending

Are
there any know issues regarding the integration of Autobahn TestSuite and
jWebSocket server?

Thanks

Assaf

···

from my client Echo’ed back nicely.

0 Likes

#2

Hi,

I am trying to use the Autobahn TestSuite python library to test my
jWebSocket server deployment on Ubuntu machine but keep getting a failed
connection message of the following type from my jWebSocket server:

ERROR - TCPConnector$ClientProcessor: Client not accepted on port XXXXX
due to handshake issues.

The log message is not very helpful .. what "issues"? File a bug against jWebSocket to improve their logging.

I followed the jWebSocket documentation regarding setting empty or null
domain but with no help.

I wrote a small java websocket client based on async-http-client java
library and it seems to connect with no problem to the server and the
messages I am sending from my client Echo'ed back nicely.

Are there any know issues regarding the integration of Autobahn
TestSuite and jWebSocket server?

I don't use jWebSocket, however since AutobahnTestsuite is used by dozens of projects (and works), it's likely an issue with jWebSocket. I'd suggest asking on their mailing list .. maybe just ask if they test jWebSocket with AutobahnTestsuite ..

···

Am 25.06.2012 09:11, schrieb assafk:

Thanks

Assaf

0 Likes