Any chance the testsuite can be downgraded to Python 2.5?

#1

I know this is a long shot, but is there any chance in making the websocket testsuite compatible with an older version of python?

Something like python 2.5?

This way the testsuite should be able to be taken as-is and wrapped up into build-tooling via jython (currently at 2.5.2)

Thanks,

  • Joakim
0 Likes

#2

Hi Joakim,

If it's only a couple of places, then yep, I'm accepting patches;)

Unfortunately, my time on this stuff is limited .. I don't event have
a 2.5 anywhere around. 2.5 is deprecated from a CPython POV. I'm not
using jython. Before 2.5, I'd probably work on 3.x support ..

Sorry,
Tobias

···

2011/11/4 Joakim Erdfelt <joakim....@gmail.com>:

I know this is a long shot, but is there any chance in making the websocket
testsuite compatible with an older version of python?
Something like python 2.5?
This way the testsuite should be able to be taken as-is and wrapped up into
build-tooling via jython (currently at 2.5.2)
Thanks,
- Joakim

0 Likes

#3

Not that important.

Was just curious if it had any value to others.

I’ll continue to use the splendid testsuite you have put together.

  • Joakim
···

On Fri, Nov 4, 2011 at 2:08 AM, Tobias Oberstein tobias.o...@gmail.com wrote:

Hi Joakim,

If it’s only a couple of places, then yep, I’m accepting patches;)

Unfortunately, my time on this stuff is limited … I don’t event have

a 2.5 anywhere around. 2.5 is deprecated from a CPython POV. I’m not

using jython. Before 2.5, I’d probably work on 3.x support …

Sorry,

Tobias

2011/11/4 Joakim Erdfelt joakim....@gmail.com:

I know this is a long shot, but is there any chance in making the websocket

testsuite compatible with an older version of python?

Something like python 2.5?

This way the testsuite should be able to be taken as-is and wrapped up into

build-tooling via jython (currently at 2.5.2)

Thanks,

  • Joakim
0 Likes