[ANN] Autobahn Java v17.10.2 with Android support

#1

I am pleased to announce the availability of Autobahn v17.10.2.

This version introduces the long-awaited WAMPv2 support for Android and fixes many long-standing bugs. We have also published the release to JCenter and Maven Central. We have published two separate packages: autobahn-java and autobahn-android.

autobahn-android provides WebSocket and WAMP implementation for Android and autobahn-java only provides WAMPv2 based on Netty’ WebSocket implementation.

Just add the below line in your gradle project’ dependencies to get started:

compile ‘io.crossbar.autobahn:autobahn-android:17.10.2’

``

We have moved the docs hosting to javadoc.io[1][2], this gives us more flexibility and automatic deployments as soon as we publish a new release.

[1] http://javadoc.io/doc/io.crossbar.autobahn/autobahn-java

[2] http://javadoc.io/doc/io.crossbar.autobahn/autobahn-android

Cheers!

0 Likes

#2

We did a quick hotfix release which fixes a manifest conflict in android, you should be using 17.10.3

···

On Tuesday, October 3, 2017 at 3:17:06 PM UTC+5, Omer Akram wrote:

I am pleased to announce the availability of Autobahn v17.10.2.

This version introduces the long-awaited WAMPv2 support for Android and fixes many long-standing bugs. We have also published the release to JCenter and Maven Central. We have published two separate packages: autobahn-java and autobahn-android.

autobahn-android provides WebSocket and WAMP implementation for Android and autobahn-java only provides WAMPv2 based on Netty’ WebSocket implementation.

Just add the below line in your gradle project’ dependencies to get started:

compile ‘io.crossbar.autobahn:autobahn-android:17.10.2’

``

We have moved the docs hosting to javadoc.io[1][2], this gives us more flexibility and automatic deployments as soon as we publish a new release.

[1] http://javadoc.io/doc/io.crossbar.autobahn/autobahn-java

[2] http://javadoc.io/doc/io.crossbar.autobahn/autobahn-android

Cheers!

0 Likes